IT技术互动交流平台

解决Discuz安装时报错“该函数需要 php.ini 中 allow_url_fopen 选项开启”

作者:Linux玩家   发布日期:2013-01-24 11:02:48

开启php的fsockopen函数 —— 解决DZ论坛安装问题“该函数需要 php.ini 中 allow_url_fopen 选项开启。请联系空间商,确定开启了此项功能

在安装dz论坛时遇到因为fsockopen()函数问题无法进入下一步,安装错误显示“该函数需要 php.ini 中 allow_url_fopen 选项开启。请联系空间商,确定开启了此项功能”,经过分析,总结了3个解决这个问题的办法:

1、首先查看php是否有禁用相关函数

找到php.ini ,打开,查找“disable_functions”,看后面是否列出了禁用函数,如果有fsockopen,说明此函数已经被禁用,直接去除此函数重新php服务,看问题是否解决,一般没有必要不必禁用函数,可将=后面的函数名全去除

2、查看allow_url_fopen是否开启

在php.ini中查找“allow_url_fopen”,看=后面是否为On,如果是Off 则说明,些函数被关闭,我们只需修改为On ,重起php服务,再去看问题是否解决

3、修改extension=php_openssl.dll

在php.ini中查找“extension=php_openssl.dll”,将前面的“;”去掉,然后重起php服务,看问题是否解决.
注:.dll是windows 特有的。如果是Linux主机,可不必尝试这个办法。 www.it165.net

解决办法总结

通过上面三种方法,对于dz论坛安装时出现“该函数需要 php.ini 中 allow_url_fopen 选项开启。请联系空间商,确定开启了此项功能”的问题,就可以有针对性的解决了!


Tag标签: Discuz  
  • 专题推荐

About IT165 - 广告服务 - 隐私声明 - 版权申明 - 免责条款 - 网站地图 - 网友投稿 - 联系方式
本站内容来自于互联网,仅供用于网络技术学习,学习中请遵循相关法律法规