IT技术互动交流平台

cisco asa 5510透明模式完整配置和ssh配置

作者:lxqyx  发布日期:2013-06-17 08:57:28

使用超级终端连接asa5510的console口,随便输入一个名称,选择对应的com口,默认为com1,
点一下 还原默认设置 确定 连续敲几下回车,出现以下内容
ciscoasa>
ciscoasa>---------备注所有端口为三层路由口
ciscoasa>
下面是基本配置信息
ciscoasa>en
Password:--------密码默认为空,直接回车
ciscoasa# conf t-------进入特权模式
ciscoasa(config)# hostname ciscoasa----重命名防火墙的名字
ciscoasa(config)#
##########################################################
ciscoasa# conf t
ciscoasa(config)# enable password ********-----设置特权模式密码
ciscoasa(config)# username ******** password ********----添加ASDM图形管理控制台用户名和密码
##########################################################
ciscoasa# conf t
ciscoasa(config)# interface e0/0----进入端口配置模式
ciscoasa(config-if)# nameif outside----添加端口名字,定义为WLAN口
INFO: Security level for "outside" set to 0 by default.  备注:默认端口安全级别为最低0,不能访问高级别的端口
ciscoasa(config-if)# no shutdown------激活端口


ciscoasa(config)# int e0/1                            
ciscoasa(config-if)# nameif inside   ------添加端口名字,定义为LAN口   INFO: Security level for "inside" set to 100 by default.                                                     
ciscoasa(config-if)# security-level 100----设置内网接口安全级别为100 可以访问级别低的外网口
ciscoasa(config-if)# no shutdown
##########################################################
ciscoasa# conf t
ciscoasa(config)# ip address ******** ********----透明模式必须配置管理ip
##########################################################
ciscoasa# conf t
ciscoasa(config)# route outside ******** ******** ********---添加默认路由(公网地址的网关)
##########################################################
ciscoasa# conf t
::ciscoasa(config)#access-list acc-nei permit ip any any----添加ACL acc-nei,允许ip协议 所有到所有
ciscoasa(config)#access-list acc-nei permit icmp any any---追加ACL acc-nei,允许icmp(ping)所有到所有
ciscoasa(config)#access-group acc-nei in interface outside---应用ACL acc-nei,到WLAN口互联网信息返回到内网(in)方向
ciscoasa(config)#------备注:每次修改ACL都要access-group把ACL应用到端口,否则不生效
##########################################################
ciscoasa# conf t
ciscoasa(config)# object-group network remote ----创建外部远程访问组
ciscoasa(config-network)# network-object host ********
ciscoasa(config-network)# network-object host ********
ciscoasa(config-network)# exit


ciscoasa# conf t
ciscoasa(config)# object-group service RMMSoft ----创建外部访问风软端口访问组
ciscoasa(config-service)# service-object tcp ********
ciscoasa(config-service)# service-object tcp ********
ciscoasa(config-service)# service-object tcp ********
ciscoasa(config-service)# exit
##########################################################


##########################################################
ciscoasa# conf t-----添加允许所有人访问rmmsoft端口和指定人访问41726端口
ciscoasa(config)# access-list acc-nei permit object-group RMMSoft any ********
ciscoasa(config)# access-list acc-nei permit tcp object-group remote host ******** eq 3389
ciscoasa(config)# access-list acc-nei permit tcp object-group remote host ******** eq 21120
ciscoasa(config)#access-group acc-nei in int outside
##########################################################
ciscoasa# conf t-------允许telnet访问
ciscoasa(config)# telnet 0.0.0.0 0.0.0.0 inside
ciscoasa(config)# passwd ********
ciscoasa(config)# http server enable
ciscoasa(config)# http ******** ******** outside
ciscoasa(config)# http ******** ******** outside
##########################################################
ciscoasa# conf t------默认外网口可以ping,只允许这两个地址ping
ciscoasa(config)# icmp permit host ******** outside
##########################################################
ciscoasa(config)# crypto key generate rsa 1024-------以下开始配置ssh,产生秘钥
ciscoasa(config)# aaa authentication enable console LOCAL-----启用本地认证
ciscoasa(config)# aaa authentication ssh console LOCAL------启用本地认证这里注意LOCAL大写
ciscoasa(config)# username duchengadmin password ducheng,@123GHJ encrypted privilege 15
ciscoasa(config)# ssh 0.0.0.0 0.0.0.0 outside
ciscoasa(config)# ssh 0.0.0.0 0.0.0.0 inside


Tag标签: cisco   asa   透明模式   ssh配置  
  • 专题推荐

About IT165 - 广告服务 - 隐私声明 - 版权申明 - 免责条款 - 网站地图 - 网友投稿 - 联系方式
本站内容来自于互联网,仅供用于网络技术学习,学习中请遵循相关法律法规