IT技术互动交流平台

OSPF环境下帧中继的配置

作者:NetworkAD  发布日期:2014-06-16 19:23:46

wKiom1OdlcmgC_gdAAFl8JSBPFY298.jpg

配置

R1=========================================================================================

frame-relay de-list 1 protocol ip list 100

interface Loopback0

 ip address 1.1.1.1 255.255.255.0

!

interface Serial1/0

 ip address 10.1.1.1 255.255.255.0

 encapsulation frame-relay

 ip ospf network point-to-multipoint

 ip ospf hello-interval 10

 ip ospf priority 255

 serial restart-delay 0

 frame-relay de-group 1 102

 frame-relay map ip 10.1.1.2 102 broadcast

 frame-relay map ip 10.1.1.3 103 broadcast

 frame-relay lmi-type cisco

!

router ospf 110

 router-id 1.1.1.1

 log-adjacency-changes

 network 1.1.1.1 0.0.0.0 area 0

 network 10.1.1.1 0.0.0.0 area 0

!

access-list 100 permit icmp host 10.1.1.1 host 10.1.1.2 //抓取想要设置DE位流量

 

R2=====================================================================================

interface Loopback0

 ip address 2.2.2.2 255.255.255.0

!

interface Serial1/0

 ip address 10.1.1.2 255.255.255.0

 encapsulation frame-relay

 ip ospf network point-to-point

 ip ospf priority 0

 serial restart-delay 0

 frame-relay map ip 10.1.1.1 201 broadcast

!

router ospf 110

 router-id 2.2.2.2

 log-adjacency-changes

 network 2.2.2.2 0.0.0.0 area 0

 network 10.1.1.2 0.0.0.0 area 0

 

R3=====================================================================================

interface Loopback0

 ip address 3.3.3.3 255.255.255.0

!

interface Serial1/0

 ip address 10.1.1.3 255.255.255.0

 encapsulation frame-relay

 ip ospf network point-to-point

 ip ospf priority 0

 serial restart-delay 0

 frame-relay map ip 10.1.1.1 301 broadcast

 frame-relay lmi-type cisco

router ospf 110

 router-id 3.3.3.3

 log-adjacency-changes

 network 3.3.3.3 0.0.0.0 area 0

 network 10.1.1.3 0.0.0.0 area 0

 

R4======================================================================================

interface Loopback0

 ip address 4.4.4.4 255.255.255.0

 ip router isis 

!

interface Tunnel100

 no ip address

 tunnel source Loopback0

 tunnel destination 5.5.5.5

!

interface Tunnel200

 no ip address

 tunnel source Loopback0

 tunnel destination 6.6.6.6

!

interface FastEthernet0/0

 ip address 45.1.1.4 255.255.255.0

 ip router isis 

!

interface FastEthernet0/1

 ip address 46.1.1.4 255.255.255.0

 ip router isis 

!

interface Serial1/1

 no ip address

 encapsulation frame-relay

 serial restart-delay 0

 frame-relay lmi-type cisco

 frame-relay intf-type dce

 frame-relay route 102 interface Tunnel100 500

 frame-relay route 103 interface Tunnel200 501

!

interface Serial1/2

 no ip address

 shutdown

 serial restart-delay 0

!

interface Serial1/3

 no ip address

 shutdown

 serial restart-delay 0

!

router isis 

 net 49.0001.4444.4444.4444.00

 is-type level-1

 log-adjacency-changes all

 

R5=====================================================================================

interface Loopback0

 ip address 5.5.5.5 255.255.255.0

 ip router isis 

!

interface Tunnel100

 no ip address

 tunnel source Loopback0

 tunnel destination 4.4.4.4

!

interface FastEthernet0/0

 ip address 56.1.1.5 255.255.255.0

 ip router isis 

!

interface FastEthernet0/1

 ip address 45.1.1.5 255.255.255.0

!

interface Serial1/1

 no ip address

 encapsulation frame-relay

 serial restart-delay 0

 frame-relay lmi-type cisco

 frame-relay intf-type dce

 frame-relay route 201 interface Tunnel100 500

!

router isis 

 net 49.0001.5555.5555.5555.00

 is-type level-1

 log-adjacency-changes all

 

R6====================================================================================

interface Loopback0

 ip address 6.6.6.6 255.255.255.0

 ip router isis 

!

interface Tunnel200

 no ip address

 tunnel source Loopback0

 tunnel destination 4.4.4.4

!

interface FastEthernet0/0

 ip address 46.1.1.6 255.255.255.0

 ip router isis 

!

interface FastEthernet0/1

 ip address 56.1.1.6 255.255.255.0

 ip router isis 

!       

interface Serial1/1

 no ip address

 encapsulation frame-relay

 serial restart-delay 0

 frame-relay lmi-type cisco

 frame-relay intf-type dce

 frame-relay route 301 interface Tunnel200 501

!

router isis 

 net 49.0001.6666.6666.6666.00

 is-type level-1

 log-adjacency-changes all

 

注:R1、R2、R3组成HUB-Spoke拓扑,并使用OSPF实现内网的网络交换,R4、R5、R6为运营商内网,使用ISIS实现内部链接,该拓扑实用于分散距离较远,分公司于总公司通过FR和多个运营商进行网络通信。

如果对以上配置有不明白的,可以留言,个人能力有限,错误之处,还请见谅!

Tag标签: OSPF   帧中继  
  • 专题推荐

About IT165 - 广告服务 - 隐私声明 - 版权申明 - 免责条款 - 网站地图 - 网友投稿 - 联系方式
本站内容来自于互联网,仅供用于网络技术学习,学习中请遵循相关法律法规