IT技术互动交流平台

关于CCNA的培训课程(3) VlanVTP中继单臂路由生成树协议

来源:IT165收集  发布日期:2016-04-11 21:28:51

这是CCNA培训课程的第三天,这一天的知识点比较多,实验的内容也逐渐开始复杂起来。

VLAN

交换机分割冲突域,不分割广播域;路由器即分割冲突域,又分割广播域。在纯粹的交换型互联网络中,如何分割广播域?答案是创建虚拟局域网(VLAN)。

VLAN(virtual local area network)是一组与位置无关的逻辑端口。VLAN就相当于一个独立的三层网络。VLAN的成员无需局限于同一交换机的顺序或偶数端口。

Access-link:接入端口,普通的交换机端口用于连接终端设备,连接到这个端口上的设备完全不知道存在着一个VLAN,它不需要知道VLAN的信息,它就认为只存在它一个VLAN即可!

全局配置模式下
vlan 10 —- 创建Vlan 10
name test —- 设置vlan name
exit
inter ran f0/1 - 15 — 分配f0/1 到 f0/15给vlan 10
swicthport access vlan 10 – 设置访问模式为access
end
show vlan brief — 查看vlan状态

特权模式下
vlan database
vlan 20 name test1
exit
conf t
inter ran f0/1 - 5
switchport access vlan 20
end
show vlan brief

中继

Trunk-link:称为干道链路,只有快速以太网口(或更高)才可以配置成干道链路,承载的是多个VLAN之间的信息,即一个交换机的一个VLAN如果想与另一个交换机的相同VLAN之间进行通讯就必须要经过这个Trunk-link.任何一个VLAN都是一样,一个交换机有三个VLAN,那么这三个VLAN就可以通过这个trunk-link链路与另一个交换机中的相同VLAN进行通讯。这样的话,不论有多少VLAN,在两个交换机中只要有一条干道链路就可以进行通讯。那肯定有人要问了,我这个交换机中的红色VLAN传一个数据到对方去,对方怎么知道就是和对方的红色VLAN进行通讯呢。在这里,主干会使用一种特殊的封装模式来对不同的VLAN进行封装,也就是对不同的VLAN打上一个标记。
  
  注: 一个交换机的任何端口都必须属于且只能属于一个VLAN,但如果某个端口被配置成TRUNK后,该端口就失去了它原来的VLAN标识,不属于任何VLAN,只是起到为所有的VLAN传输数据。

inte f0/1
switchport mode trunk — 设置端口为中继

VTP

VTP(VLAN Trunking Protocol):是VLAN中继协议,也被称为虚拟局域网干道协议。它是思科私有协议。作用是十几台交换机在企业网中,配置VLAN工作量大,可以使用VTP协议,把一台交换机配置成VTP Server, 其余交换机配置成VTP Client,这样他们可以自动学习到server 上的VLAN 信息。

Server(服务器模式):在VTP服务器上能创建、修改和删除VLAN,同时这些信息会在Trunk链路上通告给域中的其它交换机;VTP服务器收到其它交换机的VTP通告后会更改自己的VLAN信息,并进行转发。VTP服务器会把VLAN信息保存在NVRAM(即flash:vlan.dat文件)中,就是重新启动交换机这些VLAN还会存在。默认情况下,交换机是服务器模式。每个VTP域必须至少有1台服务器,当然也可以有多台。

Client(客户机模式):在VTP客户机上不允许创建、修改和删除VLAN,但它会监听来自其它交换机的VTP通告并更改自己的VLAN信息,接收到的VTP信息也会在Trunk链路上向其它交换机转发,因此这种交换机还能充当VTP中继;VTP Client把VLAN信息保存在RAM中,交换机重启动后这些信息会丢失。

Transparent(透明模式):的交换机不完全参与VTP。可以在这种模式的交换机上创建、修改和删除VLAN,但是这些VLAN信息并不会通告给其它交换机,它也不接受其它交换机的VTP通告而更新自己的VLAN信息。然而,它会通过Trunk链路转发收到的VTP通告从而充当了VTP中继的绝色,因此完全可以把该交换机看成是透明的。VTP Transparent仅会把本交换机上的VLAN信息保存在NVRAM中。

实验:
sw1#delete flah:vlan.dat
sw1#erase startup-config
sw1#reload
sw1(config)#int f0/15
sw1(config-if)#switchport trunk encapsulation dot1q
sw1(config-if)#switchport mode trunk
sw1(config)#vtp mode server —- server模式
sw1(config)#vtp domain VTP-Test
sw1(config)#vtp password cisco
sw1(config)#vlan 2
sw1(config-vlan)#name two
sw2#delete flah:vlan.dat
sw2#erase startup-config
sw2#reload

sw2(config)#int range f0/1 - 2
sw2(config-if-range)#switchport trunk encapsulation dot1q
sw2(config-if-range)#switchport mode trunk
sw2(config)#vtp mode transparent —- 透明模式
sw2(config)#vtp domain VTP-Test
sw2(config)#vtp password cisco

sw3#delete flah:vlan.dat
sw3#erase startup-config
sw3#reload
sw3(config)#int f0/15
sw3(config-if)#switchport trunk encapsulation dot1q
sw3(config-if)#switchport mode trunk
sw3(config)#vtp mode client —- 客户模式
sw3(config)#vtp domain VTP-Test
sw3(config)#vtp password cisco
sw1#show vtp status //查看VTP域的状态

单臂路由

单臂路由,即在路由器上设置多个逻辑子接口,每个子接口对应一个vlan。在每个子接口的数据在物理链路上传递都要标记封装。Cisco设备支持ISL和802.1q(dot1Q)协议。华为只支持802.1q。

r1
inter f0/0 – 打开f0/0端口
no shutdown
exit

interface f0/0.10 – 设置f0/0端口为逻辑端口 f0/0.10 对应Vlan 10
encapsulation dot1Q 10 — 设置封装协议
ip add 192.168.1.1 255.255.255.0 – 设置Vlan IP
exit
interface f0/0.20 – 设置f0/0端口为逻辑端口 f0/0.20 对应Vlan 20
encapsulation dot1Q 20
ip add 192.168.2.1 255.255.255.0
exit

生成树协议

生成树的工作原理:
生成树协议的国际标准是IEEE802.1d.运行生成树算法的网桥/交换机在规定的间隔内通过网桥协议数据单元(BPDU)的组播帧与其他交换机交换配置信息,其工作的过程如下: 
 1. 通过比较网桥/交换机优先级选取根网桥/交换机(给定广播域内只有一个根网桥/交换机); 
 2. 其余的非根网桥/交换机只有一个通向根网桥/交换机的端口,称为根端口;  
 3. 每个网段只有一个转发端口;  
 4. 根网桥/交换机所有的连接端口均为转发端口。

生成树协议的算法过程可以归纳为三个步骤:
选择根网桥、选择根端口、选择指定端口。  
(1)选择根网桥:
在全网中选择一个根网桥,比较网桥的BID值,值越小其优先级越高。ID值是由两部分组成的:交换机的优先级和MAC地址组成的,如果交换机的优先级相同则比较其MAC地址,地址值越小,其就被选举为根网桥。  
(2)选择根端口:在每个非根交换机上选择根端口  
首先,比较根路径成本,根路径成本取决于链路的带宽,带宽越大,路径成本越低,则选该端口为根端口。其次,如果根路径成本相同,则要比较所在对端交换机BID值,值越小,则其优先级越高  最后,比较端口的ID值,该值分为两部分:端口优先级和端口编号,值小的被选为根端口  
(3)选择指定端口:在每条链路上选择一个指定端口,根网桥上所有端口都是指定端口。
首先,比较根路径成本,  其次,比较端口所在网桥的ID值  最后,比较端口的ID 值

综合实验:

这里写图片描述路由器,不同网段也可以ping通,但是对于交换机,处于不同的Vlan之间是不能连通的,因为处于不同的广播域。

Tag标签: 单臂   培训课程   路由  
  • 专题推荐

About IT165 - 广告服务 - 隐私声明 - 版权申明 - 免责条款 - 网站地图 - 网友投稿 - 联系方式
本站内容来自于互联网,仅供用于网络技术学习,学习中请遵循相关法律法规