IT技术互动交流平台

CCNA网络工程师学习进程(6)vlan相关协议的配置与路由器简单配置介绍

作者:MenAngel  来源:IT165收集  发布日期:2016-12-16 20:35:46

    前面已经介绍了大部分与vlan技术相关的交换机的协议的配置,更深层次的还有STP协议和以太网端口聚合技术,接着还会简单介绍一下路由器的基本应用。

    (1)STP(Spanning-tree Protocol)

    问题引入:

    在由交换机构成的局域网络中通常设计有冗余链路和设备。这种设计的目的是防止一个点的失败导致整个网络功能的丢失。虽然冗余设计可能消除的单点失败问题,但也导致了回路的产生,它会带来如下问题:

1 广播风暴  
2 同一帧的多份拷贝
3 不稳定的MAC地址表

    1)STP的简单介绍:

    生成树协议,又称扩展树协定,是一基于OSI网路模型的数据链路层(第二层)通讯协定,用作确保一个无回圈的区域网络环境。通过有选择性地阻塞网络冗余链路来达到消除网络二层环路的目的,同时具备链路的备份功能。

    STP用于解决局域网的环路问题,它通过在交换机之间实行冗余连接的同时,避免网络环路的出现,实现网络的高可靠性。

    STP的配置命令:

  

    当局域网中有多个VLAN并且Trunk链路负载过重时,可能需要划分多个Trunk端口实行负载分担(均衡),而STP能够解决由此产生的环路问题。当同一台交换机的两个口形成环路时,STP端口权值用来决定哪个口是交换状态的,哪个口是阻断状态的。(STP端口权值实现负载均衡)

    交换机的端口状态:

关闭(disable): 端口处于管理关闭状态
阻塞(blocking): 不能转发用户数据
监听(listening): 接口开始启动
学习(learning): 学习MAC地址, 构建MAC表进程项
转发(forwarding): 可以转发用户数据   

    在PacketTracer模拟器中,交换机默认启用生成树协议,橙色的端口表明处在阻塞状态。

  

    2)STA(Spanning Tree Algorithm)算法:

    IEEE802.1D标准定义了STP的生成树算法。该算法依赖于BID路径开销端口ID参数:

    生成树协议的算法过程:

  生成树协议的算法过程可以归纳为三个步骤:选择根网桥、选择根端口、选择指定端口。  
(1)选择根网桥:在全网中选择一个根网桥
  比较网桥的BID值,值越小其优先级越高。ID值是由两部分组成的:交换机的优先级和MAC地址组成的,如果交换机的优先级相同则比较其MAC地址,地址值越小,其就被选举为根网桥;  
(2)选择根端口:在每个非根交换机上选择根端口
  首先,比较根路径成本,根路径成本取决于链路的带宽,带宽越大,路径成本越低,则选该端口为根端口。其次,如果根路径成本相同,则要比较所在对端交换机BID值,值越小,则其优先级越高。最后,比较端口的ID值,该值分为两部分:端口优先级和端口编号,
值小的被选为根端口;
(3)选择指定端口:在每条链路上选择一个指定端口,根网桥上所有端口都是指定端口  
  首先,比较根路径成本,其次,比较端口所在网桥的ID值,最后,比较端口的ID值。

    BPDU(Bridge Protocol Data Unit):

    网桥协议数据单元是一种生成树协议问候数据包,它以可配置的间隔发出,用来在网络的网桥间进行信息交换。

  

    BID(Bridge ID):

    BID由优先级,发送交换机的Mac地址和扩展系统ID(可选)组成。两台交换机的优先级可能相同,但Mac地址不相同,确保了BID的唯一性。而扩展系统ID的目的是为了节约Mac地址。

    不使用扩展系统ID时:(版本老,因此在dynamips中完成):

    BID=优先级(16个字节)+Mac地址(48个字节)

    开启SW1,并配置交换机,并用show spanning-tree brief 命令查看各vlan下交换机的BID:(在真实机上使用show spanning-tree)

en
vlan database
vlan 10 name vlan10
exit
conf t
host SW1
int f1/1
switchport mode access
switchport access vlan 10
exit

    vlan 10的Mac地址是vlan 1的Mac地址+1。

    使用扩展系统ID:

    BID=优先级(4个字节)+扩展系统ID(12个字节,可以看做vlan ID)+Mac地址(48个字节)。

  

    在左侧交换机查看BID:

  

   从Root ID=vlan 1的BID可以看出此交换机是vlan 1的跟交换机,与图中显示一致。

   在交换机上创建vlan 10和vlan 20,将左侧交换机设置为vlan 10的根交换机,右侧交换机设置为vlan 20的根交换机:

   拓展知识:在网络中如果我想要更改根交换机,可以用下述方法:

1.在没有扩展系统ID的情况下:
spanning-tree vlan 1 priority 0-65535
2.在有扩展系统ID的情况下:
spanning-tree vlan 1 priority 0-4096

    SW1的配置命令:

en
conf t
host SW1
vlan 10
name vlan10
vlan 20
name vlan20
exit
int f0/3
switchport mode access
switchport access vlan 10
int range f0/1-2
switchport mode trunk
switchport trunk allowed vlan all
end
conf t
spanning-tree vlan 10 priority root
end

    SW2的配置命令:

en
conf t
host SW2
vlan 10
name vlan10
vlan 20
name vlan20
exit
int f0/3
switchport mode access
switchport access vlan 20
int range f0/1-2
switchport mode trunk
switchport trunk allowed vlan all
end
conf t
spanning-tree vlan 20 priority 4096
end

  

    两个交换机的STP协议配置情况:

  

    路径开销:

    端口花费默认和端口的带宽有关,路径花费等于根交换机到最终交换机前进方向的端口花费总和。

    端口花费的参考值:

 

    在选取根端口的过程中,修改端口花费:

int f0/1
spanning-tree cost 1-65536

    当STA决定使用一条路径之后,STA配置交换机的端口角色,端口的角色描述了它与根桥的关系和是否允许转发流量:

1.RP根端口 :  非根交换机上离根交换机最近的端口(在该端口所在路径的花费最小),每个非根交换机有且仅有一个。
2.DP指派端口:  每个网段都有一个指派端口,该端口指该网段到跟交换机最近的交换机上的端口
3.非指派端口:  既不是根端口也不是指派端口
4.禁用端口:    被shutdown的端口

    PID=端口优先级+端口号:

    修改端口优先级:

int f0/1
spanning-tree port-priority 0-255

    选取根端口:

1.比较花费,花费小的将成为根派端口;
2.在花费相同的情况下比较发送者的BID;
3.在发送者BID相同的情况下比较发送者的PID;
4.在前面都相同的基础上比较接收者的PID;

    选取指派端口:

1.比较花费,花费小的成为指派端口;
2.比较BID,BID小的成为指派端口;
3.交换机上PID小的成为指派端口;

    3)配置示例:

    1.3.1生成树的选举:

  

    生成树的选举过程:

1.比较三台交换机BID:由于优先级相同,mac地址小的将成为根交换机;
2.对于SW2来说,由于路径花费相同,发送者的BID也相同,而下面链路的发送者的PID(f0/1端口)较小,因此下面的端口为根端口;
3.对于SW3来说,左侧端口的路径花费较小,因此左侧端口成为根端口;
4.对于网段三,由于路径花费相同,SW2的BID小,因此f0/3将成为根端口;

    1.3.2STP协议实现vlan的负载均衡,包括STP端口权值和路径权值两种方式:

  

    在SW1和SW2上进行初始vlan 配置:(SW1和SW2配置命令相同)

en
conf t
host SW1
vlan 10
name vlan10
vlan 20
name vlan20
int f0/1
switchport mode access
switchport access vlan 10
int f0/2
switchport mode access
switchport access vlan 20
int range g0/1-2
switchport mode trunk
switchport trunk allowed vlan all
end

    STP端口权值实现vlan的负载均衡:

en
conf t
int g0/1
spanning-tree vlan 1,10 port-priority 16
int g0/2
spanning-tree vlan 20 port-priority 16
end

    STP路径权值实现vlan的负载的负载均衡:(PacketTracer 不支持,需要在dynamips中实现)

en
conf t
int g0/1
spanning-tree vlan 1,10 cost 38
int g0/2
spanning-tree vlan 20 cost 38
end

    (2)交换机端口聚合:

    端口聚合也叫做以太通道(Ethernet Channel),主要用于交换机之间连接。交换机能把一组物理端口联合起来,做为一个逻辑的通道,也就是channel-group。

    端口汇聚可以分为手工汇聚、基于IEEE 802.3ad标准的LACP(Link Aggregation Control Protocol,链路聚合控制协议)和思科私有的PAgP(Port Aggregation Protocol,端口聚合协议)。

    配置实例:

    在图中交换机上配置两条以太网信道,每两个端口组成一组,有两个vlan 10,20并且不同vlan优先通过不同的组。

  

    SW1和SW2的配置命令:

conf t
host SW1
vlan 10
exit
vlan 20
exit
interface f0/1
switchport mode access
switchport access vlan 10
interface f0/2
switchport mode access
switchport access vlan 20
exit
int range f0/21-24
switchport mode trunk
switchport trunk allowed vlan all
exit
interface port-channel 1
switchport mode trunk
switchport trunk allowed vlan all 
no shutdown
exit
interface range f0/21-22 
channel-group 1 mode on 
no shutdown
exit
interface port-channel 2
switchport mode trunk
switchport trunk allowed vlan all
no shutdown
exit
interface range f0/23-24
channel-group 2 mode on 
no shutdown
exit

    先在交换机上输入命令后连接两台交换机:

  

    配置STP实现负载均衡:

  SW1和SW2的配置:

en
conf t
interface port-channel 1
spanning-tree vlan 1,10 port-priority 16
exit
interface port-channel 2
spanning-tree vlan 20 port-priority 16
exit
end

  

    配置的最终效果:

  

    在之前做过三层交换机以太网端口聚合相关配置,现在做两层交换机的配置发现还是有区别的:三层交换机在逻辑端口需要封装协议:switchport trunk encapsulation dot1q.

    (3)路由器的简单介绍及简单配置:

    路由器是因特网的主要节点设备,其主要作用是进行路由计算,将报文从一个网络转发到另一个网络。当路由表中有多个路由信息与目标网络匹配时,则遵循子网掩码最长匹配原则(即选择匹配的最小范围子网)进行路由。

    路由器常常用于将用户的局域网连入广域网,因此很多路由器既有普通的以太网络端口,又有串行端口(用于连接广域网设备)。

    端口配置和路由配置是路由器最主要的配置内容。端口配置包括普通以太网络端口的配置和串行端口的配置。

    路由配置包括静态路由配置、默认路由配置和动态路由配置

    1)以太网端口的配置:

    配置端口的命令:

  

    2)串行端口的配置:

    路由器串行端口常用的配置命令:

  

    DCE与DTE:

    同步串行端口的同步时钟信号是由DCE(数据通讯设备,如modem)提供的。默认情况下,路由器串行端口充当DTE。如果查看到该端口是DTE(数据终端设备,如计算机)类型,不必配置同步时钟参数;如果查看到端口是DCE类型,就必须用命令指定时钟频率来配置成DCE端。在串行端口连接中,作为DCE的一端必须要为连接的另一DTE提供时钟信号。

    HDLC:

    路由器出厂时,默认的串口封装协议是HDLC(全称High level Data Link Control,高级数据链路控制)。HDLC是面向比特的数据链路控制协议,它不依赖于任何一种字符编码集;数据报文可透明传输,用于实现透明传输的“0比特插入法”易于硬件实现;全双工通信,有较高的数据链路传输效率;所有帧采用CRC检验,对信息帧进行顺序编号,可防止漏收或重份,传输可靠性高;传输控制功能与处理功能分离,具有较大灵活性。

    配置实例:

  

    DCE端的配置:

en
conf t
int s0/0/0
ip add 192.168.1.1 255.255.255.0
clock rate 9600
bandwidth 64
no shut

    DTE端的配置:

en
conf t
int s0/0/0
ip add 192.168.1.2 255.255.255.0
bandwidth 64
no shut

  可能出现的错误:

  

  解决方法:出现这种现象是由于在DTE端配置了时钟频率,用DCE或DTE串口线连接路由设备时一定要注意分清哪个是DCE端,哪个是DTE端。

实验文档下载: http://files.cnblogs.com/files/MenAngel/NetBlog6.zip

Tag标签: 路由器   进程   工程师  
  • 专题推荐

About IT165 - 广告服务 - 隐私声明 - 版权申明 - 免责条款 - 网站地图 - 网友投稿 - 联系方式
本站内容来自于互联网,仅供用于网络技术学习,学习中请遵循相关法律法规