• 热门专题

jQuery 1.10.0和jQuery 2.0.1发布

作者:  发布日期:2013-05-27 10:34:35
Tag标签:jQuery  
  • 据 jQuery 官博 5 月 24 日博文,宣布同时发布 jQuery 1.10.0 和 jQuery 2.0.1。以下是官博文章的部分摘译:

    今天是发布软件的好日子,真的是好日子。我们有两个版本要发布!今天是 jQuery 1.10.0 和 jQuery 2.0.1 的首演。 jQuery 1.10.0  距 jQuery 1.2.6 的发布世界有五年之久。

    尽管同时发布两个版本总是不容易,但成功了就很容易让人有成就感。团队肯定对这两货的交付很满意;那些之前已经升级到 1.9/2.0 版本的用户,对这两个版本,应当有一份轻松时间。如果你是在更新旧代码,那 jQuery 1.9 升级指南中的建议,仍然有用。同时也别忘了,jQuery 2.0 是不支持 IE 6、7、8 的,不过 1.x 系列是支持低版本的 IE 浏览器。如果你在升级或维持 1.9 版之前旧版方面需要帮助,别忘了有 jQuery 迁移插件

    和往常一样,最新版本放在我们的下载页面了。

    这两个版本有什么新东西呢?我们的主要目标是同步 1.x 和 2.x 产品线中的特性和行为,正如一年前我们发布 jQuery 2.0 时所承诺的一样。展望未来,我们尽量保持同步,所以 1.11 和 2.1 特性相当。我们不期望你会发现有什么颠覆性的变化。这里有些亮点:

    宽松的 HTML 解析:$(htmlString) 的标签之前,你可以再次有空格或换行。在解析从外部源获取的 HTML 时,我们仍强烈建议你使用  $.parseHTML() ,我们或许在将来对 HTML 解析做更近一步的改变。

    Increased modularity:在这两个版本中,你现在可定制 build 排除 .wrap().wrapAll(),.wrapInner().unwrap() 方法。如果你的全部代码都是在用从 jQuery 1.7 中引入的更新的 .on() 事件方法,那你也排除 .bind().delegate() 方法。这些 build 已在 jQuery 和 Google 这可用,微软的 CDNs 继续包括所有方法,以提供最大的兼容性。

    No more IE9 focus of death:如果在一个网页准备好之前,该网页中的 iframe 企图聚焦某个元素,或者甚至想要读取 document.activeElement ,那就会引发报错。我们目前在解决这个问题。

    Cordova bug fix in 2.0.1:Cordova deviceready 事件并没有很好设置事件目标,所以我们通过向 document 设置目标,解决了问题。

     

    非常感谢那些参与 jQuery 1.10.0 和 jQuery 2.0.1 的朋友:Brandon Johnson、 Chris Talkington、Dmitry Gusev、James Burke、 Jason Bedard、Julian Aubourg、Kyle Robinson Young、Mark Raddatz、Michał Gołębiowski,、Nguyen Phuc Lam、Oleg Gaidarenko、Renato Oliveira dos Santos、Richard Gibson、Rick Waldron、Scott González、Timmy Willison、Timo Tijhof 和 Tom H Fuertes。


延伸阅读:

About IT165 - 广告服务 - 隐私声明 - 版权申明 - 免责条款 - 网站地图 - 网友投稿 - 联系方式
本站内容来自于互联网,仅供用于网络技术学习,学习中请遵循相关法律法规