IT技术互动交流平台

WordPress默认主题存在跨站攻击漏洞

发布日期:2015-05-07 20:42:37

根据外媒arstechnica援引国外安全研究机构sucuri.net的报告称,WordPress 的默认主题TwentyFourteen存在跨站攻击漏洞。此漏洞允许攻击者使用该主题内置的一个ico图标生成文件(genericons)来进行攻 击,研究机构称,漏洞来自此ico图标生成文件,所以任何应用了此功能的主题或者插件都受到了影响,目前已知的有默认主题TwentyFourteen和 插件jetpack(安装次数超过100万)受此影响。

漏洞文件

该漏洞的验证地址如下:安全人员建议开启网站防火墙的WAF攻击防御措施来抵御此攻击。当然彻底修复该漏洞的方法也很简单,直接删除目录genericons即可避免。

漏洞演示

目前GoDaddy、DreamHost等主机商和公司已经主动修复该漏洞,但截至发稿前从官方网站下载的最新版WordPress4.2.1依然存在此目录和漏洞。

Tag标签: 漏洞   主题  
  • 专题推荐

About IT165 - 广告服务 - 隐私声明 - 版权申明 - 免责条款 - 网站地图 - 网友投稿 - 联系方式
本站内容来自于互联网,仅供用于网络技术学习,学习中请遵循相关法律法规