IT技术互动交流平台

思科修复高危网络安全设备漏洞

作者:佚名  发布日期:2016-05-24 20:20:32


这些缺陷可以被专门制作的HTTP请求利用从而引起拒绝服务的条件
思科系统已经修复了四个拒绝服务漏洞,这些漏洞可以被攻击者利用从而导致网络安全设备停止正确地处理网络流量。
思科网络安全设备(WSA)是一系列的安全设备,它们检查按照一定形式组织的流入和流出网络流量,用以检测恶意软件,防止数据泄漏,并为用户和应用程序实施互联网接入策略。这些设备运行一个名为思科AsyncOS的操作系统。
周三被思科修复的四个DoS漏洞中的一个漏洞是源于该操作系统如何处理特定的HTTP响应代码。攻击者可以发送一个专门制作的HTTP请求来耗尽被攻击设备的整个内存空间。
如果发生这种情况,该设备将不再接受新传入的连接请求,思科的一个顾问说。
所有思科AsyncOS系统9.0.1-162以下版本都受到影响。建议用户升级到9.1版本,该版本未受到攻击。
另一个DoS漏洞是由于组成HTTP POST请求的数据包缺乏适当的输入验证。该缺陷可以通过专门精心设计的HTTP请求被利用,并可能导致代理过程变得反应迟钝,WSA重载。
受此漏洞影响的只有AsyncOS 8.0版本。用户可以升级到8.0.6-119或9.0.1-162,其中包含了所有四个缺陷修复的补丁,思科的一个顾问说。
第三个漏洞源于未能释放内存当文件范围通过WSA请求缓存的内容。通过打开多个连接和请求文件范围,攻击者可以使WSA耗尽内存,从而停止传送流量。
版本8.5到8.8的AsyncOS系统受到了影响,思科建议升级到9.0.1-162版本。
第四个漏洞发生是因为AsyncOS不恰当地为HTTP报头和预期HTTP负载分配空间。利用这一缺陷会导致代理流程重新加载和流量停止。
该缺陷会影响AsyncOS版本8.8和更低版本。思科已经在版本8.5的分支版本8.5.3-069和版本9.0.1-162 中修复了该漏洞。
除了WSA缺陷,思科也修补了一个温和的跨站点脚本漏洞,该漏洞存在于思科统一计算系统(UCS)核心软件的Web界面。
 

Tag标签: 思科   漏洞   网络安全  
  • 专题推荐

About IT165 - 广告服务 - 隐私声明 - 版权申明 - 免责条款 - 网站地图 - 网友投稿 - 联系方式
本站内容来自于互联网,仅供用于网络技术学习,学习中请遵循相关法律法规